M365 outbound not working for some customers
Incident Report for ALCiT
Postmortem

Issue was linked to an expired certificate on an email gateway. Only customers with strict certificate verification were affected.

Posted Aug 23, 2023 - 20:13 EDT

Resolved
This incident has been resolved.
Posted Aug 23, 2023 - 20:12 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 23, 2023 - 19:34 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 23, 2023 - 19:13 EDT
This incident affected: Advanced Email Security.