Service Desk is not available or not updating

Incident Report for ALCiT

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:20 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 16:55 EDT

Update

Service Desk is better, confluence is still down.
Posted Oct 20, 2025 - 16:01 EDT

Identified

This is linked to an ongoing outage with Atlassian ( https://status.atlassian.com/ )
Posted Oct 20, 2025 - 09:21 EDT
This incident affected: Service Desk.