Microsoft Teams is experiencing issues
Incident Report for ALCiT
Resolved
This incident has been resolved.
Posted Jan 27, 2024 - 07:50 EST
Update
Mostly back to normal
Posted Jan 26, 2024 - 21:36 EST
Update
Service is still degraded for some users.
Posted Jan 26, 2024 - 20:00 EST
Update
Microsoft has confirmed that this is an widespread issue (tracked by Microsoft has TM710344).
Posted Jan 26, 2024 - 14:08 EST
Investigating
We are currently investigating this issue.
Posted Jan 26, 2024 - 13:47 EST
This incident affected: Microsoft 365 (all customers).